?

Log in

No account? Create an account

Previous Entry | Next Entry

IE Issues?

  • Sep. 20th, 2007 at 9:43 PM
Hi, all. I apologize in advance if this isn't the kind of thing you guys can help me with! But I'm still really new at LJ layouts, and as much CSS experience as I've got under my belt, I'm really stumped by the way my otherwise functional layout renders in IE (6).

The layout is here; http://community.livejournal.com/standonthesky/

(More apologies, I know the code is a bit ugly and still all in the head instead of a neat, separate CSS file, and I know there are a lot of !important declarations. Honest, I don't normally code this way!)

Essentially, I'm really hoping some of you experts can help me figure out what kind of overrides to put in there so that the IE version works, too. I'm thinking absolute positioning instead of fixed positioning would help, although I was trying to avoid it so that the dreaded navstrip wouldn't be hidden behind divs.

And, as the image map would indicate, this is on a paid account.

Thanks in advance!

Comments

av8rmike
Sep. 21st, 2007 01:42 pm (UTC)
Out of curiousity, did you try disabling the base stylesheets through the Customization Wizard or in the theme layer? Something weird is going on because it's trying to load a non-existent stylesheet.

If you make the theme layer's source viewable and provide the ID, I could probably help out with that.
libekory
Sep. 21st, 2007 01:59 pm (UTC)
I think that's me, attempting to wedge IE's conditional comments in there. (I really just want two declarations, absolute positioning on the relevant divs, but since I wasn't sure how much else I'd need to fiddle with, I was just going to make an extra stylesheet called ie.css.) So far the layer does not like them, which is such a shame.

Boy it's been a while since I last tried anything like this -- I don't remember how to make a theme public. *much bowing and scraping and appreciation for all your help so far, by the way*
av8rmike
Sep. 21st, 2007 03:01 pm (UTC)
At the top, with the rest of the layerinfo:
layerinfo "source_viewable" = 1;
libekory
Sep. 21st, 2007 05:36 pm (UTC)
Okay, done -- like hours later; sorry!

9146479
av8rmike
Oct. 1st, 2007 12:27 pm (UTC)
It still doesn't look quite right in IE... the page scrolls, but the graphic on the left looks "smeared" below the floating links.

(Sorry about the delay.. work has been unusually busy the last few weeks trying to get some software ready.)
libekory
Oct. 1st, 2007 05:12 pm (UTC)
At this point, that's deliberate. I made a "pixel-drag" background image for IE so that at least it wouldn't look so plain; without JavaScript, there's nothing I can do to get IE6 to emulate the fixed positioning.

I'm sure IE7 still looks a bit off, but I used an underscore hack to feed the "fixed" code only to IE6, so it should be getting the fixed-position code like all the other browsers. (I much prefer conditional comments to things like this, but I was unable to get them to display; the layer compiler ate the code.)

Latest Month

March 2016
S M T W T F S
  12345
6789101112
13141516171819
20212223242526
2728293031  

S2 Help Communities

Tags

Powered by LiveJournal.com
Designed by chasethestars